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1 Introduction

The goal of this tutorial is to introduce a method of creating aircraft wings in the 3D computer

aided design program SolidWorks. This tutorial is appropriate for users who have limited

to no experience with SolidWorks. Supplementary guides and tutorials can be found on the

MEAM.Design Wiki page at http://alliance.seas.upenn.edu/ medesign/wiki.

2 Defining the Airfoil

There are two straightforward methods of defining the airfoil profile.

Figure 1: Sketch of Airfoil Geometry, from Kroo “Airfoil Geometry” [1]

Online Profile Generator The first method involves using a web-based NACA 4-digit

series profile generator [2]. The airfoil profile is determined by three parameters, which

correspond to the four digits of the NACA airfoil. The first digit corresponds to the

degree of camber, the second to the position of the camber, and the third and forth to

the thickness (expressed as a percentage of chord length).
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1. This tool can be found at http://www.ppart.de/aerodynamics/profiles/NACA4.html.
1 Toggle the sliders until you achieve the desired airfoil.

Figure 2: Web-based profile generator and Excel file containing airfoil profile data points

2. Copy the coordinate points and paste into a new Microsoft Excel document.

3. Depending on the version of Excel being used, sometimes both the x and y data

points show up in the same column when copied from the Profile Generator table.

To fix this problem so that column A corresponds to x -axis points only, and

column B corresponds to y-axis points only, click on Data (in the toolbar)→ Text

to Columns. Within the Convert Text to Columns Wizard, select delimited for

original data type and then tab and space as the delimiters. Now the x and y data

should be in two different columns.

Using the Equation For a 4-Digit NACA Airfoil The second method involves using

NACA formulas to define the shape of the airfoil.

1Profile generators for NACA 5 digits series and ellipses can also be found at
http://www.ppart.de/aerodynamics/profiles/NACA5.html and .../profiles/Ellipse.html, re-
spectively.
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1. To define the shape of a symmetrical 4-digit NACA airfoil (i.e. NACA 00xx):
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2. For a cambered 4-digit airfoil, we must first define the mean camber line using the

following piecewise equation:
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Once the mean camber line is defined, the coordinates of the upper and lower

airfoil surface (xU ,yU) and (xL,yL) are given by:

xU = x− y sin θ, yU = yc + y cos θ

xL = x+ y sin θ, yL = yc − y cos θ

3 Drawing the Airfoil Curve

1. Create a new SolidWorks part document

2. From the toolbar select Tools → Options → Document Properties (tab) to units. Select

the desired unit system. Since we have data points for a unit-length airfoil, the chord

of the airfoil will be one of whatever unit the document is in. The chord length can

then be specified by scaling the profile after it is inserted.

3. From the toolbar select Insert → Curve → Curve Through XYZ Points...

4. A window titled Curve File will appear. Within this window, select Browse.... Change

Files of type: from Curves (*.sldcrv) to Text Files (*.txt) and then select the file

containing the airfoil profile points.

5. Once the profile points are in the Curve File window, select OK. A curve is now inserted

into the SolidWorks model view.

6. The curve we have just inserted shows up as Curve1 in the FeatureManager design tree

on the left hand side of the screen. However, in order to create solid geometry, we must

first convert this curve into a sketch.
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Figure 3: Curve file window

Figure 4: After creating a sketch and converting curve entities, the airfoil appears with black
lines in the SolidWorks model view.

7. To create a sketch that is based on the curve, first insert a new sketch by selecting the

Sketch tool from the CommandManager toolbar. SolidWorks should by default insert

the airfoil curve on the front plane, so select the front plane as the sketch plane.

8. Now we can create a sketch defined by the airfoil curve by first selecting the curve and

then selecting Convert Entities, which can be found in the CommandManager toolbar.

The curve should appear black in color, which indicates a fully defined sketch. We are

now ready to use this sketch to create 3D geometry.

4 Creating 3D Geometry

This section details methods of creating 3D wings from the 2D airfoil profile.
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Extruded Feature Extruding the sketch profile will create a simple wing. This feature

will not provide any curvature to the wing, nor will it allow the wing to be tapered

gradually towards the tip.

1. From the CommandManager toolbar, select Extruded Boss/Base.

2. If your sketch is not already selected, you will be asked to select an existing sketch

to use for the feature. Select the sketch of the airfoil profile.

3. From the FeatureManager, change the depth of the extrusion to achieve the desired

span.

4. Click the green check mark to execute the feature, and save the .SDLPRT file.

Figure 5: An extruded feature

Swept Feature Sweeping the sketch profile through a path provides a higher degree of

flexibility in comparison to the extrusion feature.

1. To begin, we must first insert a path line through which the profile will be swept.

Once again, a curve can be inserted from a .txt file containing data points in the

same manner in which the airfoil profile was inserted, but it is also possible to

simply insert a new sketch and draw a line or a spline.

2. Make sure you have exited the sketch containing the profile, and then select Sketch

and then Sketch again from the CommandManager toolbar.
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3. The panel on the left hand side of the screen will ask you to select a plane on

which to create a sketch. With the airfoil profile already oriented on the front

plane, select the top plane (if the planes are not displayed, open up the part tree).

4. Orient the view such that you are normal to the top plane. This can be ac-

complished be either opening the Standard Views drop-down menu in the View

toolbar, or by pressing the spacebar on the keyboard and selecting top.

5. Select either the line or spline tool from the CommandManager toolbar, and create

the desired sweep path next to the airfoil profile, avoiding any automatic relations

SolidWorks may try to insert.

6. Select Add Relation from the CommandManager toolbar and select the endpoint

of the path line and the profile sketch.

7. Within the Add Relations side panel, define the relation as Pierce. Select the

green check mark to insert the relation. This relation is necessary to create a

swept feature.

8. Exit the sketch and select Swept Boss/Base from the feature option in the Com-

mandManager toolbar.

9. The Sweep sidebar will ask you to select a sweep profile and a sweep path. Select

the airfoil profile sketch as the sweep profile, and the line/spline sketch as the

sweep path.

10. Notice that the span and shape of the wing depends on the sweep path sketch that

was previously inserted. If you would like to go back and change the length or path

of the sweep path, first select the green check mark to execute the sweep feature.

An item entitled Sweep1 appears in the FeatureManager design tree. Expand the

sweep feature by selecting the plus symbol next to it, right-click on the sketch that

contains the sweep path, and select Edit Sketch. Any changes made to the sweep

path will automatically rebuild in the sweep feature after you exit the sketch.

11. The sweep feature can also be edited by right-clicking on it in the design tree.

Some options that may be of interest can be found in the Orientation/twist type

drop-down menu. For example, if you are creating prop blades, you may want to

have the airfoil profile twist along the path.

Lofted Feature Lastly, we can employ the loft feature to create wings that have longitudinal

twist, bend, and a non-constant chord length. 2

2Additionally, we could even use lofts to create wings with non-constant airfoil geometry.
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Figure 6: A swept feature with a curved profile path

1. To use the loft feature, we must insert a new plane as reference geometry. Before

dong this, first right-click the front plane in the FeatureManager design tree, and

select show.

2. Now go to Insert → Reference Geometry → Plane. Select the front plane from

the model view, and set the distance between this plane and the new plane to be

the desired span of the wing. Select the green check mark to insert the plane. The

reference geometry plane should appear in the model view and the design tree.

3. Insert a new sketch on the reference plane (probably named Plane1 ).

4. Orient the view normal to the reference plane, select the airfoil profile that is

sketched on the front plane, and convert entities. This tool copies the airfoil curve

into the sketch on the reference plane.

5. In the case of wanting to create a wing with a non-constant chord length (i.e. a

‘taper’) we can scale the airfoil sketch on the reference plane. To do this, select

Tools → Sketch Tools → Scale.

6. If the sketch isn’t already selected, select the airfoil curve on the reference plane.

Spline2 will appear in the Entities to Scale box in the side panel.

7. Under Parameters, you must choose a point to scale about. You can click anywhere

in the sketch to define a point to scale about. Finally, specify a scale factor, and

select the green check mark to execute.
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Figure 7: Inserting a reference plane and scaling a sketch

8. Insert a loft by selecting Lofted Boss/Base from the CommandManager toolbar.

9. In order to create a loft, we must select at least two profiles. Select the airfoil

profile sketch on the front plane and the scaled-down profile sketch on the reference

plane.

10. The loft generated by SolidWorks is most likely not the loft that is desired. There

are many different ways in which we can modify the loft feature. First, you will

notice a teal-blue circle that appears on each of the selected profiles. These circles

mark the points that are synchronized between the profiles. These markers can be

clicked-and-dragged around to modify the synchronization between the profiles.

Figure 8: A lofted feature with a scaled-down end profile
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11. The start/end constraints can also be modified to create the differently shaped

wings. Within the Start/End Constraints box in the Loft editor, change Start

Constraint from None to Normal to Profile. This option causes the loft faces to

start normal to the sketch profile. If the start constraint for the airfoil profile

sketch is Normal to Profile at the root, and there is no constraint on the scaled-

down profile at the tip of the wing, the resulting loft will be parabolic in shape.

12. Guide curves can also be used for lofted features in a way that is similar to how

they are used for swept features. In lofts, guide curves specify the geometry

between the profiles.

13. Although there are other options that can be used in loft features, the last option

I will mention is using multiple scaled and/or rotated airfoil profiles in a single

loft. In this way, the wing geometry can be highly specified.

5 Measurements, Mass Properties, Rendering

Once the wing is created, SolidWorks is capable of telling you some useful information

about the wing, such as the dimensions, surface area, and moments about various axes

(once a material is assigned). Finally, realistic material renderings can be produced

using the PhotoWorks tool.

Measurements SolidWorks is capable of determining the dimensions and surface area of

the wing.

Figure 9: Making measurements
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1. Go to Tools → Measure.

2. To determine the span of the wing select the flat face at both the root and tip end

of the wing. SolidWorks will display the distance between the two faces, as well

as a breakdown of the distance in (x,y,z) components.

3. The surface area of the wing can be determined by selecting the curved surface of

the geometry.

Mass Properties Additionally, one can assign a material to the geometry to obtain infor-

mation on the mass properties of the wing, such as total mass, center of mass, and the

moments of inertia about various axes.

Figure 10: Mass properties window

1. A material must be assigned to the wing before SolidWorks can provide infor-

mation about its mass properties. To do this, right-click in the FeatureManager

design tree where it says Material not specified, and select Edit Material.

2. If the wing is to be printed using the Dimension Elite 3-D printer, select ABS

(under plastics) as the material. If the wing is going to be fabricated from a series

of laser-cut acrylic segments, select Acrylic (Medium-high impact).

3. Notice that at the bottom of the Materials Editor side panel there is a box titled

Physical Properties. Properties such as elastic modulus, Poisson’s ratio, shear
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modulus, density, etc. are provided by SolidWorks, assuming that a material was

assigned.

4. Select the green check mark to save the material to the wing.

5. Now, select Tools → Mass Properties. Various mass properties, such as center of

mass (relative to the part origin), and the moments of inertia about various axes

are computed.

Rendering Lastly, one can prepare attractive SolidWorks renderings of the wing geometry

using the PhotoWorks feature, a rendering tool that is built in to the SolidWorks

program.

1. On the right-hand side of the screen, select the PhotoWorks Items button to

display the PhotoWorks task pane.

2. Select a renderable material from the task pane, and drag the material name onto

the SolidWorks part.

3. To add a background scene and lighting, do the same for any of the various

Studios. Lights can also be inserted manually by dragging a light into the window

containing the part.

Figure 11: Renderings of the swept feature (left) and lofted feature (right). The material
shown is polished aluminum and the studio is Daytime.
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